logo-foundation-shadow.jpg

I got tired of seeing names with male #xxxx or female #xxxx, so created a list of names. Decided to share it, knowing others might feel the same way.



Details

RankDownloadsCreatorAddedUpdated
3 of 9319 (12 today)Crash

Releases

FilenameUploaderSizeVersionAddedOptions
names.4.zipCrash9.64kb1.0.3

names.3.zipCrash9.56kb1.0.2

names.2.zipCrash10.81kb1.0.1

names.1.zipmaximebrodat9.71kb1.0.0

names.zipCrash9.84kb1.0.0

8 comments

SC
schwarzie2478 @schwarzie2478

Hey, I was trying to make a mod of names based on your mod with names I would recognize, but they don't appear in the game I just made, I installed the mod in the correct place, I selected the mod and the log shows it was loaded. Is it just adding names or replacing them? Also I only had a male version so I removed the female part from your mod, is that the problem. Lastly does it replace names in existing games? Any tips would be helpfull. Thanks for the works already!

SC
schwarzie2478 @schwarzie2478

Nevermind, it works, in my initial test was, the mod was not active apparantly! Super

C
Crash @crash

Good News, everything is working.

C
Crash @crash

Good New and Bad News. Always start with the good, I can create custom names for villagers. I have done many test over that last week and I can get names into the game. Bad News, seems to be a limit on the number of names that the game will load. Most likely for memory usages. Nothing I do removes the "Sex #xxx" from the villager list.

C
Crash @crash

I'm doing another test. Prior to using the mod, names would stop around 70. Now I can get my population to about 100 before seeing the #xxx. Maybe something the devs could look into. Is there a hard code limit to the number of names the game can look up? As anyone else seeing this? I am testing again with maximebrodat changes.

MA
maximebrodat @maximebrodat

According to the logs, it's actually your mod not loading, leo is looking into it.

C
Crash @crash

Thank you, I did follow leo example. Please let me know what you find. I'll also see if I can get something to work.

C
Crash @crash

I think I figured it out. I removed some code I thought was not needed and I used single quotes not double quotes. Testing Now.